Reports of Reader Slowdowns

Incident Report for Dripos

Postmortem

Dear Dripos Partners,

After yesterday’s incident, you may need to process offline orders or re-connect card readers if you got logged out at any period! Please see below for some helpful resources for your team.

To reconnect an existing card reader, please see here: https://support.dripos.com/hardware/reader/reader-s700-trouble#how-to-repair-an-existing-reader

For common troubleshooting after being back online after using offline mode, please see here: https://support.dripos.com/updates/product-updates#system-wide-outage-july-17%2C-2025

Thank you again for your patience during yesterday’s incident. Our sincerest apologies for this inconvenience during business hours, we understand that these events can have an extremely negative impact on your business. Our entire team is committed to ensuring no such issues are ever a norm on our platform, and we are continuing to put structures into place that prevent slowdowns or outages. We appreciate your continued partnership.

Of course, please don’t hesitate to reach out to our support line or email if we can help troubleshoot or answer any questions!

Best,
The Dripos Team

Posted Jul 18, 2025 - 13:17 EDT

Resolved

We have confirmed resolution across devices on all platforms, and all systems are fully operational. If you turned off your tablet wifi during this incident, you can now turn this wifi back on and process offline payments.

Please see our guide on resolving any lingering issues: https://support.dripos.com/updates/product-updates#july-17%2C-2025

Thank you for your patience as we resolved this issue! As always, we appreciate your continued partnership. Don't hesitate to reach out at support@dripos.com with any further questions or concerns.
Posted Jul 17, 2025 - 18:34 EDT

Monitoring

A fix to platform slowdowns has been implemented and we are seeing slow recovery across locations. We are continuing to monitor!

If you turned your POS wifi off, please turn this back on and process offline payments. More on processing offline payments here: https://support.dripos.com/orders/platforms/platforms-offline#process-offline-orders
Posted Jul 17, 2025 - 18:19 EDT

Update

We are continuing to work all hands on deck to restore full functionality to all Dripos platforms. If this issue is affecting your POS, please turn off your tablet's wifi and process payments offline. Thank you for your patience as we continue to resolve this issue!
Posted Jul 17, 2025 - 17:49 EDT

Identified

We are continuing to resolve the issue currently causing slowdowns and offline issues on POS and readers. You may also have trouble accessing the Dripos Web Dashboard at this time.

If this issue is affecting your POS, please turn your tablet wifi off and process payments offline. Thank you for your patience as we continue to resolve this issue!
Posted Jul 17, 2025 - 17:29 EDT

Update

If you see a warning that says 'Employee Authentication Failed,' please press NO and do not log out. We are continuing to resolve this issue with highest priority!
Posted Jul 17, 2025 - 16:53 EDT

Update

As we continue to investigate and resolve this issue, please kick your POS offline and process offline orders if you are experiencing issues. Thank you for your patience as we continue to resolve this!
Posted Jul 17, 2025 - 16:44 EDT

Investigating

We've received reports of slowdowns on the POS and taking card payments on readers at some locations. We are actively investigating impacted locations with highest priority.

We’ll continue to provide updates as we make progress. We appreciate your patience as we work to restore full service to affected partners as quickly as possible.
Posted Jul 17, 2025 - 16:21 EDT
This incident affected: Point of Sale, Card Readers, and Dashboard.