Follow-up: Stripe Interruption 9/19

Incident Report for Dripos

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 12:58 EDT

Update

Related to this previous Stripe issue, we've pushed a key update to the Point of Sale. If you see an update on your POS, please ensure you update. The most recent version is v1.11.66-2g.
Posted Sep 21, 2025 - 21:38 EDT

Monitoring

In relation to today’s issues with our payments partner, Stripe, it is possible that some Register Devices may be showing offline until reset correctly.

To ensure a smooth weekend, we recommend you check your Register Devices in the morning prior to opening. If you experience your POS reading offline even though your internet is working correctly, please reach out to Dripos Support immediately at (781) 583-3699. Our team will walk you through the correct steps to bring you back online.

If calling, please press 1 to reach our urgent team, or text our number stating your shop name, and noting you are offline. Our team is fully staffed through the weekend and ready to help, if needed!
Posted Sep 19, 2025 - 16:41 EDT
This incident affected: Point of Sale and Card Readers.