Our team is fully staffed and actively monitoring the platform today as we continue rolling out fixes and improvements. The updated server infrastructure has remained stable overnight and this morning.
To reconnect to the updated environment, some locations may need to restart their POS devices before beginning service today. If you run into any issues at all, please contact our support team directly and we’ll help immediately.
We know how disruptive yesterday was, especially during a busy holiday weekend, and we appreciate everyone’s patience while we worked through it.
Posted May 10, 2026 - 07:55 EDT
Monitoring
Our engineers have deployed a fix to resolve today’s outage. All POS and card reader functionality has been restored.
To bring your system back online, please complete these steps: Re-enable WiFi (if disabled during the outage) Restart the POS app Update to the latest app version: v1.13.86-i
Then, please confirm the following settings: POS Settings → Advanced Settings → toggle OFF “Enter Offline Mode” POS Settings → Tickets & KDS → Fire Ticket Settings → set to “Checkout is Complete (Default)” — Note: This setting will be fully restored system-wide later this week.
If you have pending offline transactions: Tap the red banner at the bottom of the POS Press “Process Orders” in the top right Processing may take up to 20 minutes depending on queue size
We are actively monitoring system stability and will continue to do so throughout the weekend. If any transactions fail to process correctly, please email support@dripos.com. We are committed to ensuring no one is financially impacted and will work with you to reimburse any lost transactions directly.
We will be sharing a full post-mortem of today’s outage later this week to provide more detail on the cause and the steps we’re taking to prevent this from happening again.
Posted May 09, 2026 - 17:43 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 09, 2026 - 17:42 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 09, 2026 - 17:41 EDT
Identified
Our engineers have pushed out an update to help resolve these issues -- please turn your WiFi back on, restart your POS app, and update the app to the latest version (v1.13.86-i). This will allow you to take manual card, cash, and gift card payments while online.
To ensure your Point of Sale is operational, please ensure the settings below are properly set: - POS Settings > Advanced Settings > Toggle off "Enter Offline Mode" - POS Settings > Tickets & KDS > Fire Ticket Settings > "Checkout is Complete (Default)"
For those with pending offline orders to process, please click the red banner at the bottom of your POS and click "Process Orders" on the top right of the screen.
Our engineers are continuing to monitor this situation and are working on ensuring the full system is back to full functionality.
Posted May 09, 2026 - 13:37 EDT
Update
Our engineers are continuing to work on resolving these issues with the highest urgency.
If you are experiencing errors taking offline transactions, turn your WiFi back on and restart the POS app to update to the latest version (v1.13.86-g). Once installed, please turn WiFi back off and continue taking Cash and Manual Card transactions while our engineers continue working on resolving this issue.
Posted May 09, 2026 - 11:47 EDT
Update
We are continuing to investigate this issue.
Posted May 09, 2026 - 11:46 EDT
Update
If you are having issues processing offline tickets via manual card or cash, please follow these steps:
1. Turn Wifi on. 2. Restart the POS and install the update to version v1.13.86-g 3. Turn Wifi off and continue to process tickets offline.
Posted May 09, 2026 - 10:29 EDT
Update
Our team is all hands on deck and continuing to work on a resolution. Expect a complete post-mortem from our team once resolved.
In the meantime, please follow these steps to ensure you can process orders on your register: 1. Turn Wifi off on the device itself or enter airplane mode. 2. Process tickets offline via manual card or cash. 3. If enabled, turn off the setting for "Fire ticket when added to cart"
All additional card processing fees will be reimbursed for any manual card transactions.
Posted May 09, 2026 - 10:02 EDT
Update
While our team continues to fix the underlying cause, our recommendation is to manually turn the wifi off on your register tablet to enter Offline Mode.
If on iOS, you can access this by swiping down from the top right of the screen and then tapping the wifi toggle to disable.
If on Android, you can access this by entering your devices settings and turning wifi off.
Posted May 09, 2026 - 09:15 EDT
Update
We are continuing to investigate this issue.
Posted May 09, 2026 - 09:08 EDT
Update
Our team is continuing to investigate the issue with POS and card reader slowdowns. At this time, we recommend entering offline mode via the "Advanced Settings" on your register device until we resolve the root cause.
Any additional processing fees for manually processed tickets will be reimbursed.
Posted May 09, 2026 - 09:06 EDT
Investigating
Our engineers are currently investigating an issue with shops experiencing POS slowdowns and card reader disconnections. Our engineers are actively working on a resolution.
If you are experiencing slowdowns, we recommend processing offline transactions. This setting can be turned on through your POS Settings > Advanced Settings > Enter Offline Mode.
Posted May 09, 2026 - 07:30 EDT
This incident affects: Point of Sale and Card Readers.