Low Risk of Card Readers becoming Unresponsive or Lagging

Incident Report for Dripos

Resolved

All impacted readers have been replaced, and we've pushed updates to work around the Stripe app for the future.
Posted May 25, 2023 - 10:28 EDT

Identified

Our payment provider Stripe has notified us they are investigating a bug regarding the connection to physical card readers that have occurred over the last two weeks. Stripe reports that some devices are entering a bad state that can not process payments or will become unresponsive or laggy.

Stripe has an all-hands-on-deck status trying to figure out a root cause and is communicating with us regularly. Only a few readers are affected on our network, and we’re currently pushing a fix to bypass Stripe’s servers.

If you have a reader that’s unable to take payments or is unresponsive, please contact Dripos support (781) 583-3699 and send them a picture of the label on the back of your card reader.
Posted May 11, 2023 - 21:15 EDT
This incident affected: Point of Sale.