Reports of Reader Slowdowns

Incident Report for Dripos

Resolved

We have confirmed resolution across all platforms and all systems are back to normal. Please turn your wifi back on if you turned it off and process all offline payments.

Please don't hesitate to reach out to support if you need any help processing payments or re-connecting readers. Our sincere apologies to the disruption to your business on a busy Saturday, we are working internally to investigate this issue thoroughly and are using all resources available to prevent this in the future.
Posted Aug 09, 2025 - 13:13 EDT

Monitoring

We are starting to see resolution to this issue on our end. If you were previously offline taking payments, please turn your tablet wifi online and quit and restart your app once. You should be able to then take payments as normal.
Posted Aug 09, 2025 - 12:47 EDT

Update

If you are experiencing issues taking manual card payments, please turn the wifi on your tablet or iPad off to take offline payments. If you see a prompt to log out of your POS, please select 'No'.

We are still investigating this issue with highest priority.
Posted Aug 09, 2025 - 12:19 EDT

Update

We are continuing to investigate this issue.
Posted Aug 09, 2025 - 12:16 EDT

Investigating

We are currently receiving some reports of reader payments slowing down. If this is affecting you, please use manual card payments in the meantime. We are investigating with highest priority.
Posted Aug 09, 2025 - 12:04 EDT
This incident affected: Point of Sale and Card Readers.