Point of Sale tablets stuck on updating
Incident Report for Dripos
Postmortem

Summary

Customers were experiencing problems with certain tablets getting stuck on an error screen after this morning’s updates. This incident occurred between 6:22 am est and 8:18 am est. This issue mainly affected non-order-taking devices like ticket screens and other back-of-house devices. No other Dripos services were affected, and most customers could still take orders with at least one of their point of sales.

Timeline

6:22 - Customer reports that the POS was stuck on an error screen after this morning’s update.

6:58 - Second report from a customer that the POS was experiencing issues. Dripos was able to identify that this was only affecting some devices with the POS installed.

7:06 - Dripos began investigating the issue to find an immediate fix.

7:14 - Dripos continued assisting customers in identifying and troubleshooting the issue via our support line.

8:18 - Dripos pushed a fix to all devices in the form of an update, solving the issue. Previously affected tablets solved the problem by uninstalling and reinstalling the app.

8:30 - The Dripos team confirmed that mostly all customers that were experiencing a problem were back to running normally.

Analysis

The root cause of the issue came from a problem with a piece of code that was changed during our weekly release. Devices save some data during checkout, and the change from last night was trying to fetch that data from tablets that didn’t have access to said data. So we fixed the piece of code to only be accessed by the correct tablets and added an extra check to prevent this from happening in the future.

We found that this only occurred for tablets that have not been used as a register, but in some rare cases, some registers were also affected. There was a workaround that could fix being stuck on the error screen that we had before releasing the hotfix, and it was used for locations that were experiencing this problem on a register.

Prevention

We’ve been significantly improving our release timing and testing, and unfortunately, this incident got through the cracks of our new systems. We are putting a lot more effort into ensuring these weekly releases are as seamless as possible for our customers. We want to keep giving our customers the ability to have new features released every week, and we’ll continue to strive and make each release better than the last.

While this incident wasn’t widespread enough to be a major incident, it was an incident no less. We want to ensure that we’re always doing our best to ensure our product is in the most stable state it can be. We’re sorry to any customers affected by the incident and hope to make it up to you in the future.

Posted Jan 10, 2023 - 19:43 EST

Resolved
All customers reporting being stuck on the loading screen have confirmed that they're back to running normally. This incident didn't affect all customers; the customers affected could still process payments through other platforms. No other Dripos product was affected.

We'll be sending a post-mortem with more details on the incident later today.
Posted Jan 10, 2023 - 09:22 EST
Identified
A few customers have notified us that some tablets after updating can be stuck in a loading state or sometimes crashes. We've found the problem, deployed a fix, and are waiting for updates from the affected customers. If you've been affected, please restart your app to update to the latest version.
Posted Jan 10, 2023 - 08:41 EST
This incident affected: Point of Sale.