Our text support issues have been resolved. Our support line is fully available and can be reached at (781) 583-3699.
Thank you for your patience.
Posted Dec 02, 2025 - 12:23 EST
Update
We continue to work with our third party text provider to bring back our text support capabilities.
Our phone support line continues to be fully available and can be reached by calling (781) 583-3699 for all inquiries during business hours or 24/7 for urgent issues. Additionally, we can be reached via email at support@dripos.com.
We sincerely apologize for this ongoing issue and thank you for your patience.
Posted Dec 01, 2025 - 17:00 EST
Update
Our text support remains unavailable as we continue to work to resolve an issue with our third party text support provider.
Our phone support line is still fully available and can be reached by calling (781) 583- 3699 for all inquiries during business hours or 24/7 for urgent issues. In addition, we can be reached via email at support@dripos.com.
We sincerely apologize for any inconvenience this may cause!
Posted Nov 30, 2025 - 13:00 EST
Identified
Due to an issue with our third party text support provider, text support is unexpectedly unavailable until Monday, December 1st.
Our phone support line is still fully available and can be reached by calling (781) 583- 3699 for all inquiries during business hours or 24/7 for urgent issues. In addition, we can be reached via email at anytime at support@dripos.com.
We are sincerely sorry for any inconvenience this may cause!