Sales Reports - Loading Currently Degraded

Incident Report for Dripos

Resolved

Our team has identified the issue and has successfully implemented a fix. Please reach out to Dripos Support if you need any help loading reports!
Posted Jul 29, 2025 - 17:07 EDT

Investigating

We’re currently investigating an issue slowing certain reports from loading, including Sales Summary, Compare Sales, Payment Methods, Discounts, Labor vs. Sales, and Ticket Type Sales.

Our team is actively working on a fix, and we’ll provide updates as soon as we have more information.
Posted Jul 29, 2025 - 16:52 EDT
This incident affected: Point of Sale and Dashboard.