Payment Processing Degraded

Incident Report for Dripos

Resolved

We're seeing a recovery across all our locations.
Posted Oct 19, 2023 - 17:02 EDT

Update

Because of the sporadic nature of this issue, if you encounter a payment error during checkout, you can retry the payment, and it should go through.

All other Dripos services are working, and we are still in contact with our payment provider over this sporadic error.
Posted Oct 19, 2023 - 16:00 EDT

Investigating

Our payment processor (Stripe) is having an incident that payments will error sporadically. We are investigating this incident with them.
Posted Oct 19, 2023 - 15:45 EDT
This incident affected: Core Server.